Smith And Wesson Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Any help would be appreciated here...did a full disassemble of the 39-2. But with the slide off I can work the trigger...put the slide on and it disengages the trigger and the mag will not full go in and slide does not go to full battery. If I pull the slide back a small amount I can get the mag in and trigger will operate.
Thanks all!
 

·
Registered
Joined
·
5,429 Posts
Sounds like you have the magazine disconnect in wrong or when you reassembled its been damaged. I would start there. Does it do this with other magazines or just one. With the magazine out the trigger will not operate. magazine disconnect. Proper proceduce to load a 39 is lock slide to the rear, de-cocker on or in the down position, insert loaded magazine drop slide under full spring tension do not let your hand ride it forward. . Should go into battery fully if not something is wrong with alignment from you re assembly. .. With magazine out trigger should not operate. With safety decocker down trigger will not operate.
 

·
Registered
Joined
·
1,739 Posts
Procedure Layne gave is right. Also if you try to force a loaded magazine in with the slide forward it may be difficult and if done in the past the spring for slide release may be out of place.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks Layne! I will check it..makes sense to check the mag depressor to see if it is bent...believe Numrich has that in stock..but glad you said that the trigger will not operate without mag in...narrows down what the issue is. And turns out not the mag depressor but the ejector depressor plunger in the slide...poke in there to see it was not moving when depressed..got it all fixed and back together! Cheers!
 

·
Premium Member
Joined
·
18,229 Posts
One other possible problem could be the reversal of the spring back to front in the magazine.
 
1 - 6 of 6 Posts
Top