Smith And Wesson Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi everyone. I read here alot but do not post much. So I have an mnp 9c2.0 . My wife got me some talon grips for it . We had to go to my mother in laws for dinner tonight so I figured I'd put em on over there while waiting for dinner to cook. Normaly I pay no attention to the sear deactivation lever if that's what it's called the litte bar you can flip to field strip the gun if you don't want to pull the trigger. Pulling the trigger dosent bother me none . I can make sure she's empty b4 doing so. So I field striped the gun and began getting ready to put the grips on.
I started to get warm like uncomfortably warm cause the oven was on so I decided I wasent going to do it right then put the stuff away and reasembled my gun. When I put the slide on and locked it back immediately something felt off. I looked at the gun and the guide rod was sticking out more than normal I think ? It happend fast . But something wasent right I knew that much. Being that I had slide the slide back to lock M it I knew the fp had been charged so I released the slide and pulled the trigger . So I could remove the slide to see that was wrong .

When I pulled the trigger there was a weird sorta metal on metal kina ping ! I was like oh crap ! Oh crap ! My wife asked what was wrong I replied something Idk but something happend ! . I may have broke it . She was like no those things should be able to take a bit of punishment. I removed the slide and the first thing I thought of was the yellow lever .So I moved it to the opposite position from what it was . I dont recall but I think it was up and I put it down . Reasemble the gun I tried to rack the slide and pull the trigger for a function check and the trigger was dead . I was like dam ! I broke it . She took it from me racked the slide and it was fine trigger went click as it should . I the took it and racked the slide and pulled the trigger and it seems fine now . I may have not racked the slide the first time I tried when it didn't function but idk.
So does anyone know what the heck that was all about . I have heard of people having problems when forgetting to move the lever back down and the slide getting stuck . I never pay any attention to it just pull the trigger remove the slide and clean. Mabey somehow this time it got swiped up? Can the thing just be removed if I'm never going to use it so this dosent happen again?
 
1 - 1 of 1 Posts
Top