Smith And Wesson Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I've been reading this forum for years, but finally joined to ask a question. Hopefully my first post won't be a dumb one that's been asked a million times! I have a gen 1 M&P 9c that I just installed a full Apex duty/carry action kit in. Install was a breeze and it's all much smoother, but I'm finding my pull isn't at all what i was expecting. I'm about 5# to the wall, and 7# to break vs the 5 I'd expected. This is with the Apex return spring and I understand that the original spring may give me about 2 more pounds, but I'm wondering if this is something anyone else has ever run into, and maybe something else is up? Tons of searching, but not finding much. I ran a couple hundred rounds through it today with no improvement. Any ideas? Thanks in advance!
 

·
Registered
Joined
·
3,158 Posts
Well I can’t say I’ve ever run into this problem because I’ve never done what you did. But I can say welcome to the forum and someone should be along soon!
 

·
Registered
Joined
·
8 Posts
Check their website, there are videos that explain what you need to do.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5 (Edited)
Thanks guys. I did follow all the directions in their videos (which are really great by the way), it's just that I wound up with a pull about 2#s heavier than they stated it should be. In reading more, though, it sounds like maybe that's just within normal variation. So, I'm told if I put that factory spring back in, (which is actually weaker than the apex carry spring), I should wind up where I want to be. Just wanted to be sure there wasn't some glaring reason for the mystery 2#s that I was missing!
 
1 - 5 of 5 Posts
Top